PEM - Hardware and Software Requirements v8.0

Edit this page

Hardware Prerequisites

For optimum performance when monitoring servers and rendering dashboards, we recommend installing PEM on a system with at least:

  • 4 CPU cores
  • 8 GB of RAM
  • 100 GB of Storage

Additional disk space is required for data storage. Please note that resource usage will vary based on which probes are defined and enabled, and the activity level on the monitored databases. Monitoring server resources (as you use PEM) will let you know when you need to expand your initial system configuration.

Software Prerequisites

Platforms and Versions Support

For information about the platforms and versions supported by PEM, visit the EnterpriseDB website at:

https://www.enterprisedb.com/services-support/edb-supported-products-and-platforms

Please note: PEM 8.0.1 is no longer supported on CentOS/RHEL/OEL 6.x platforms. It is strongly recommended that EDB products running on these platforms be migrated to a supported platform.

Modifying the pg_hba.conf File

The pg_hba.conf file manages connections for the Postgres server. You must ensure that the pg_hba.conf file on each monitored server allows connections from the PEM server, the monitoring PEM Agent, and the host of the PEM-HTTPD server.

For information about modifying the pg_hba.conf file, see the PEM Administrator's Guide.

Information about managing authentication is also available in the Postgres core documentation.

Firewall Restrictions

Please note that you must adjust your firewall to allow communication between PEM components.

Supported Locales

Currently, the PEM server and web interface support a locale of English(US) en_US and use of a period (.) as a language separator character. Using an alternate locale, or a separator character other than a period may result in errors.