Installation v1.0

Edit this page

This section walks you through installing EDB PgBouncer on a CentOS, Debian/Ubuntu, or a Windows host.

The following table lists the latest PgBouncer versions, their supported corresponding Advanced Server versions, and the supported platforms for each PgBouncer version.

The PgBouncer version is version-specific, but the documented and supported functionality of each version is the same. The information in this guide applies to each version listed in the table below.

Pgpool VersionAdvanced Server VersionSupported Platforms
PgBouncer 1.15PostgreSQL and Advanced Server 13RHEL/CentOS 7 - x86_64 and RHEL/CentOS 8 - x86_64
RHEL/CentOS 7 - ppc64le
Debian 9x Stretch and Debian 10x Buster
Ubuntu 18.04 Bionic Beaver and Ubuntu 20.04 LTS Focal Fossa
Windows 86 x64 Interactive Installer
PgBouncer 1.15PostgreSQL and Advanced Server 12RHEL/CentOS 7 - x86_64 and RHEL/CentOS 8 - x86_64
RHEL/CentOS 7 - ppc64le
Debian 9x Stretch and Debian 10x Buster
Ubuntu 18.04 Bionic Beaver
Windows 86 x64 Interactive Installer
SUSE Linux Enterprise Server 12 SP4
PgBouncer 1.15PostgreSQL and Advanced Server 11RHEL/CentOS 7 - x86_64 and RHEL/CentOS 8 - x86_64
RHEL/CentOS 7 - ppc64le
Debian 9x Stretch
Ubuntu 18.04 Bionic Beaver
Windows 86 x64 Interactive Installer
SUSE Linux Enterprise Server 12 SP4
PgBouncer 1.15PostgreSQL and Advanced Server 10 and 9.6RHEL/CentOS 7 - x86_64
RHEL/CentOS 7 - ppc64le
Debian 9x Stretch
Ubuntu 18.04 Bionic Beaver
Windows 86 x64 Interactive Installer
PgBouncer 1.14Advanced Server 13RHEL/CentOS 7 - x86_64 and RHEL/CentOS 8 - x86_64
RHEL/CentOS 7 - ppc64le
Debian 9x Stretch and Debian 10x Buster
Ubuntu 18.04 Bionic Beaver and Ubuntu 20.04 LTS Focal Fossa
Windows 86 x64 Interactive Installer
PgBouncer 1.14Advanced Server 12RHEL/CentOS 7 - x86_64 and RHEL/CentOS 8 - x86_64
RHEL/CentOS 7 - ppc64le
Debian 9x Stretch and Debian 10x Buster
Ubuntu 18.04 Bionic Beaver
Windows 86 x64 Interactive Installer
PgBouncer 1.14Advanced Server 11, 10, and 9.6RHEL/CentOS 7 - x86_64 and RHEL/CentOS 8 - x86_64
RHEL/CentOS 7 - ppc64le
Debian 9x Stretch
Ubuntu 18.04 Bionic Beaver
Windows 86 x64 Interactive Installer
SUSE Linux Enterprise Server 12 SP4
PgBouncer 1.13Advanced Server 12RHEL/CentOS 7 - x86_64 and RHEL/CentOS 8 - x86_64
RHEL/CentOS 7 - ppc64le
Debian 9x Stretch
Ubuntu 18.04 Bionic Beaver
Windows 86 x64 Interactive Installer
PgBouncer 1.12Advanced Server 12RHEL/CentOS 7 - x86_64 and RHEL/CentOS 8 - x86_64
RHEL/CentOS 7 - ppc64le
Debian 9x Stretch
Ubuntu 18.04 Bionic Beaver
Windows 86 x64 Interactive Installer
PgBouncer 1.9Advanced Server 11RHEL/CentOS 7 - x86_64
RHEL/CentOS 7 - ppc64le
Debian 9x Stretch
Ubuntu 18.04 Bionic Beaver
Windows 86 x64 Interactive Installer and Linux 86_64 Interactive Installer
PgBouncer 1.7Advanced Server 10 and 9.6RHEL/CentOS 7 - x86_64
RHEL/CentOS 7 - ppc64le
Windows 86 x64 Interactive Installer and Linux 86_64 Interactive Installer
Note

PgBouncer 1.15 is no longer supported on CentOS/RHEL/OEL 6.x platforms. It is strongly recommended that EDB products running on these platforms be migrated to a supported platform.

installing_pgbouncer_on_a_linux_or_centos_host installing_pgbouncer_on_a_debian_or_ubuntu_host installing_pgbouncer_on_an_sles_host installing_pgbouncer_on_a_windows_host