3.6 Advanced Server RPM Installers

Table of Contents Previous Next


3 Using a Package Manager to Install Advanced Server : 3.6 Advanced Server RPM Installers

The tables that follow list the packages that are available from EnterpriseDB. Please note that you can also use the yum search command to access a list of the packages that are currently available from your configured repository. To use the yum search command, open a command line, assume root privileges, and enter:
Where package is the search term that specifies the name (or partial name) of a package. The repository search will return a list of available packages that include the specified search term.
The Meta Installer installs Advanced Server and its core supporting components. This package installs:
The edb-as96-server-client package contains client programs and utilities that you can use to access and manage Advanced Server.
The edb-as96-contrib package installs contributed tools and utilities that are distributed with Advanced Server. Files for these modules are installed in:
Documentation: /usr/edb/as9.6/share/doc
Loadable modules: /usr/edb/as9.6/lib
Binaries: /usr/edb/as9.6/bin
The edb-as96-server-core package includes the programs needed to create the core functionality behind the Advanced Server database.
The edb-as96-server-devel package contains the header files and libraries needed to compile C or C++ applications that directly interact with an Advanced Server server and the ecpg or ecpgPlus C preprocessor.
The edb-as96-server-docs package installs the SGML source for the PostgreSQL documentation, as well as the documentation in HTML and PDF format.
The edb-as96-server-libs package provides the essential shared libraries for any Advanced Server client program or interface.
The edb-as96-server-plperl package installs the PL/Perl procedural language for Advanced Server. Please note that the edb-as96-server-plperl package is dependent on the platform-supplied version of Perl.
The edb-as96-server-plpython package installs the PL/Python procedural language for Advanced Server. Please note that the edb-as96-server-plpython package is dependent on the platform-supplied version of Python.
The edb-as96-pltcl package installs the PL/Tcl procedural language for Advanced Server. Please note that the edb-as96-pltcl package is dependent on the platform-supplied version of TCL.
The edb-edbplus package contains the files required to install the EDB*Plus command line client. EDB*Plus commands are compatible with Oracle's SQL*Plus.
The edb-as96-postgis package includes files used to add PostGIS functionality to Advanced Server
The edb-as96-postgis-core package includes PostGIS supporting files.
The edb-as96-postgis-docs package provides PostGIS documentation files.
The edb-jdbc package includes the .jar files needed for Java programs to access an Advanced Server database.
The edb-migrationtoolkit package installs Migration Toolkit, facilitating migration to an Advanced Server database from Oracle, PostgreSQL, MySQL, Sybase and SQL Server. Migration Toolkit requires Java (version 7 or 8), or OpenJDK (version 1.7 or 1.8).
The edb-oci package installs the EnterpriseDB Open Client library, allowing applications that use the Oracle Call Interface API to connect to an Advanced Server database.

3 Using a Package Manager to Install Advanced Server : 3.6 Advanced Server RPM Installers

Table of Contents Previous Next