EDB Postgres Backup and Recovery Installation Guide v2.6

This guide provides information about how to install and configure the EDB Backup and Recovery Tool (BART) 2.6.

Requirements Overview

Supported Platforms and Database Versions

Note

BART is not supported by EDB Postgres Advanced Server or PostgreSQL version 14 and later. EDB strongly recommends you move to Barman or pgBackRest as your backup recovery tool. See Moving to a New Backup Tool for more information.

  • BART supports the following database versions:

    • Advanced Server versions 9.6, 10, 11, 12, and 13.
    • PostgreSQL versions 9.6, 10, 11, 12, and 13.

Software Requirements

You require the following components to install BART.

  • BART Host Components - Use EDB packages to add BART host components; see Installing BART for information about how to install these components.

  • Additional Components - In addition to the BART host components, the following components are required:

Limitation

BART supports taking only a full backup of standby servers; it does not support taking incremental or parallel backups of standby servers.